Tips en Trucs Microsoft Excel #2: Verticaal zoeken met VERT.ZOEKEN header image

Tips en Trucs Microsoft Excel #2: Verticaal zoeken met VERT.ZOEKEN

zaterdag 31 maart 2018 ·Leestijd: 3 minuten
contacteer auteur:

In een ander blogitem is al eens aangegeven dat wij Accessify WCMS zo inrichten dat onze klanten gemakkelijk informatie kunnen wijzigen, bijvoorbeeld productinformatie. Wij beseffen dat veel van onze klanten Microsoft Excel gebruiken om mutaties te doen op data die zij hebben en dus zorgen wij ervoor dat de content zoveel mogelijk via Excel bijgewerkt kan worden.

Microsoft Excel is een krachtig programma en je kan snel veel bewerkingen uitvoeren om je data te verrijken of een goed overzicht te creëren. Deze resultaten zijn daarna eenvoudig te importeren in Accessify WCMS. In het vorige blogitem is gesproken over Voorwaardelijke opmaak, Filteren en sorteren op basis van kleur en Celinhoud bewerken zonder bestaande inhoud te verwijderen. Een ander krachtig hulpmiddel om relevante gegevens op te halen en te ordenen in je spreadsheet is Verticaal zoeken.

Verticaal zoeken

Met verticaal zoeken kan je een bepaalde waarde gebruiken om een corresponderende waarde uit een rij met waardes te halen. Dat klinkt ingewikkeld, maar dat valt mee: stel je voor dat je een lijst met postcodes van klanten met bestellingen hebt en je wilt weten welke stad erbij hoort:

Bestellingen met daarin postcodes:

lijst-postcodes

Lijst met steden per postcode:

lijst-postcodes-per-stad

In mijn voorbeeld heb ik de lijst met postcodes per stad uiteraard klein gehouden en ook op een ander werkblad geplaatst, om aan te geven dat je hiermee je spreadsheet overzichtelijker houdt.

Ik zou nu per bestelling handmatig de stad kunnen opzoeken en deze ernaast typen. Bij zes bestellingen is dat te doen, bij 6.000 niet meer (of zelfs niet meer bij zestig). Ik kan nu gebruikmaken van de Verticaal-zoeken-functionaliteit van Microsoft Excel om de steden automatisch te vullen. Je gebruikt hiervoor de functie VERT.ZOEKEN. Omdat mijn postcodes ook bestaan uit letters, wil ik eerst alleen de eerste vier karakters van de postcode vinden, hiervoor gebruik ik de functie LINKS: LINKS(A2; 4).

VERT.ZOEKEN verwacht vier parameters:

  1. De waarde die ik ga opzoeken, in dit geval de eerste vier karakters van de postcode bij een bestelling: LINKS(A2; 4). (A2 uiteraard voor de eerste bestelling, A3 voor de tweede, et cetera.)
  2. Het kolombereik met daarin de kolom waarin ik de postcode ga opzoeken en de kolom met de steden, de eerste twee kolommen van het werkblad Postcodes dus: Postcodes!A:B
  3. Het kolomnummer in het bereik met het resultaat, in dit geval is dat de tweede kolom: 2.
  4. En of de waarde exact of niet-geheel exact moet overkomen. Dit laatste houdt in dat als er niets wordt gevonden, er een resultaat uit een bijna overeenkomende cel wordt teruggegeven. Dat is vrijwel nooit nodig, dus vullen we hier ONWAAR in.

De formule is dan: =VERT.ZOEKEN(LINKS(A2; 4);Postcodes!A:B;2;ONWAAR). Het resultaat, als ik de formule in alle cellen onder “Stad” plak:

resultaat-vert-zoeken-zonder-waarde

We zien hier dat de waarde kennelijk niet wordt gevonden. De reden? LINKS maakt een tekstuele waarde van de postcode en in het werkblad ‘Postcodes’ staan ze als cijfer. De oplossing? Er cijfers van maken, via WAARDE (WAARDE(LINKS(A2; 4))). De formule wordt dan: =VERT.ZOEKEN(WAARDE(LINKS(A2; 4));Postcodes!A:B;2;ONWAAR) en het resultaat:

resultaat-vert-zoeken-met-waarde

Zo kan je eenvoudig en snel je data aanvullen, om deze daarna te importeren in Accessify WCMS en te gebruiken in je website of webshop.


Andere blogartikelen

Integraties met API's van verschillende partijen
Geschreven door
op donderdag 30 juni 2022
Bij Sigma Solutions maken wij integraties met verschillende partijen, die ervoor zorgen dat jouw bedrijfsproces geautomatiseerd en gedigitaliseerd kan worden. We zijn constant op zoek naar passende oplossingen voor onze klanten.
Wat is B2B Online Advertising?
Geschreven door
op donderdag 30 juni 2022
B2B Online Advertising is een marketingstrategie die bedoeld is om een zakelijke boodschap over te brengen aan andere bedrijven door middel van advertenties.
Als traditioneel bedrijf succesvol blijven in een tijdperk van digitalisering
Geschreven door
op donderdag 30 juni 2022
Wil je als traditioneel bedrijf succesvol blijven in een tijdperk van 'digital natives'? Lees dan deze blogpost!
Open Nieuwsbrief Inschrijving Footer

E-book

Zo wordt uw website een lead generator 
In 3 stappen uw website van visitekaartje naar salesfunnel

Download het E-book â€ș