Tips en Trucs Microsoft Excel #2: Verticaal zoeken met VERT.ZOEKEN

Geschreven door: op zaterdag 31 maart 2018

Leestijd: 3 minuten

In een ander blogitem is al eens aangegeven dat wij Accessify WCMS zo inrichten dat onze klanten gemakkelijk informatie kunnen wijzigen, bijvoorbeeld productinformatie. Wij beseffen dat veel van onze klanten Microsoft Excel gebruiken om mutaties te doen op data die zij hebben en dus zorgen wij ervoor dat de content zoveel mogelijk via Excel bijgewerkt kan worden.

Microsoft Excel is een krachtig programma en je kan snel veel bewerkingen uitvoeren om je data te verrijken of een goed overzicht te creëren. Deze resultaten zijn daarna eenvoudig te importeren in Accessify WCMS. In het vorige blogitem is gesproken over Voorwaardelijke opmaak, Filteren en sorteren op basis van kleur en Celinhoud bewerken zonder bestaande inhoud te verwijderen. Een ander krachtig hulpmiddel om relevante gegevens op te halen en te ordenen in je spreadsheet is Verticaal zoeken.

Verticaal zoeken

Met verticaal zoeken kan je een bepaalde waarde gebruiken om een corresponderende waarde uit een rij met waardes te halen. Dat klinkt ingewikkeld, maar dat valt mee: stel je voor dat je een lijst met postcodes van klanten met bestellingen hebt en je wilt weten welke stad erbij hoort:

Bestellingen met daarin postcodes:

lijst-postcodes

Lijst met steden per postcode:

lijst-postcodes-per-stad

In mijn voorbeeld heb ik de lijst met postcodes per stad uiteraard klein gehouden en ook op een ander werkblad geplaatst, om aan te geven dat je hiermee je spreadsheet overzichtelijker houdt.

Ik zou nu per bestelling handmatig de stad kunnen opzoeken en deze ernaast typen. Bij zes bestellingen is dat te doen, bij 6.000 niet meer (of zelfs niet meer bij zestig). Ik kan nu gebruikmaken van de Verticaal-zoeken-functionaliteit van Microsoft Excel om de steden automatisch te vullen. Je gebruikt hiervoor de functie VERT.ZOEKEN. Omdat mijn postcodes ook bestaan uit letters, wil ik eerst alleen de eerste vier karakters van de postcode vinden, hiervoor gebruik ik de functie LINKS: LINKS(A2; 4).

VERT.ZOEKEN verwacht vier parameters:

  1. De waarde die ik ga opzoeken, in dit geval de eerste vier karakters van de postcode bij een bestelling: LINKS(A2; 4). (A2 uiteraard voor de eerste bestelling, A3 voor de tweede, et cetera.)
  2. Het kolombereik met daarin de kolom waarin ik de postcode ga opzoeken en de kolom met de steden, de eerste twee kolommen van het werkblad Postcodes dus: Postcodes!A:B
  3. Het kolomnummer in het bereik met het resultaat, in dit geval is dat de tweede kolom: 2.
  4. En of de waarde exact of niet-geheel exact moet overkomen. Dit laatste houdt in dat als er niets wordt gevonden, er een resultaat uit een bijna overeenkomende cel wordt teruggegeven. Dat is vrijwel nooit nodig, dus vullen we hier ONWAAR in.

De formule is dan: =VERT.ZOEKEN(LINKS(A2; 4);Postcodes!A:B;2;ONWAAR). Het resultaat, als ik de formule in alle cellen onder “Stad” plak:

resultaat-vert-zoeken-zonder-waarde

We zien hier dat de waarde kennelijk niet wordt gevonden. De reden? LINKS maakt een tekstuele waarde van de postcode en in het werkblad ‘Postcodes’ staan ze als cijfer. De oplossing? Er cijfers van maken, via WAARDE (WAARDE(LINKS(A2; 4))). De formule wordt dan: =VERT.ZOEKEN(WAARDE(LINKS(A2; 4));Postcodes!A:B;2;ONWAAR) en het resultaat:

resultaat-vert-zoeken-met-waarde

Zo kan je eenvoudig en snel je data aanvullen, om deze daarna te importeren in Accessify WCMS en te gebruiken in je website of webshop.


Andere blogartikelen

  • Overeenkomsten tussen Growth Hacking en UX design

    Geschreven door: op zondag 13 september 2020

    Laten we beginnen met wat Growth hacking is, Growth hacking zijn experimenten voor oplossingen die groeiproblemen moeten oplossen. Dit is een nieuwe marketing aanpak die met name wordt gedreven door d ...

    Bekijk het artikel »
  • B2B SEO en Geoptimaliseerde Afbeeldingen

    Geschreven door: op woensdag 12 augustus 2020

    In een tijd waarin 27% van het koopproces van B2B kopers met eigen online research wordt doorgebracht is het essentieel om een goed vindbare website te hebben. Afbeeldingen kunnen, indien geoptimalise ...

    Bekijk het artikel »
  • Prospects zoeken B2B

    Geschreven door: op woensdag 12 augustus 2020

    Het zoeken van B2B prospects is een uitdaging voor elk bedrijf. Met name kwalitatieve B2B prospects.Door vooraf onderzoek te doen naar bedrijven die voldoen aan je criteria en je marketing hierop aan ...

    Bekijk het artikel »
Bel 072 5345 888
Meer dan 40 bedrijven vertrouwen op ons
Allrig is de alles in een leverancier binnen de energie-industrie
AOC is een toonaangevend wereldwijd bedrijf actief in de verkoop van kwaliteitsharsen
ERIKS is een toonaangevende en innovatieve leverancier aan de procesindustrie en aan machinebouwers, die zowel de rol van specialist als die van brede MRO-leverancier vervult
Industrieel dienstverlener Heinen & Hopman Engineering uit Bunschoten is dé wereldwijde specialist op het gebied van klimaatbeheersing
Handicare is een internationale organisatie die ouderen helpt om hun dagelijks leven gemakkelijker te maken door het produceren van hoogwaardige trapliften
Op de hoogte blijven?

Meld u aan voor de gratis nieuwsbrief om op de hoogte te blijven van onze activiteiten